忍者ブログ
[323] [322] [321] [320] [319] [318] [317] [316] [315] [314] [313]

DATE : 2017/10/21 (Sat)
×

[PR]上記の広告は3ヶ月以上新規記事投稿のないブログに表示されています。新しい記事を書く事で広告が消えます。


DATE : 2007/07/10 (Tue)

使っていた Apache HTTP Server のバージョンが2.0.54と古かった(現在の最新の2.0系は2.0.59)ので、Apache HTTP Server のバージョンを上げるついでに、2.2系に移行しました。

2.0系の時の設定も2.2系のものに移し終え、サーバを立ち上げます。ところが、次のようなエラーが出てきてしまいました。

mod_dav_svn.so is garbled - perhaps this is not an Apache module DSO?

「mod_dav_svn.so」というのは、Apache HTTP Server と Subversion とを接続するために必要となる Apache モジュールです。Subversion に付属してくるものなのですが、どうも Apache HTTP Server 2.2系には対応していないようです orz

ところが、いろいろとネットを調べてみると、2.2系向けにコンパイルされた mod_dav_svn.so が見つかりました。それを Subversion 付属のものと置き換えてみると、きちんと動作しました。

というわけで、以下にその入手先を掲載しておきます。なお、対象となる Subversion のバージョンは 1.4.4 以下 、OS は Windows です(同入手先には、1.3.x 用のものもあります)。

入手先は、「Subversion 1.3 mod_dav_svn for Apache 2.2」のトピックです。このページの下2つの投稿に掲載されている「mod_dav_svn.so」と「mod_authz_svn.so」です。

(;^ω^)これは、Windows 版の Apache HTTP Server 2.2系特有の現象のようです(Re: svn 1.4 and apache 2.2.3

参考文献

追記

Subversion 1.4.5 から、Apache 2.0 用モジュールと 2.2 用モジュールの両方が用意されるようになりました。

そのため、本記事は Subversion 1.4.4 以下が対象となります(また、そのように本記事を修正しました)。

PR
忍者ブログ [PR]
ブログ内検索
最近の状況
リンク
カレンダー
09 2017/10 11
S M T W T F S
1 2 3 4 5 6 7
8 9 10 11 12 13 14
15 16 17 18 19 20 21
22 23 24 25 26 27 28
29 30 31
使用許諾
最新コメント
(08/15)
(05/04)
(03/06)
(03/04)
(09/25)
最新トラックバック
T/O
(11/05)
ブログ内検索
最近の状況
リンク
カレンダー
09 2017/10 11
S M T W T F S
1 2 3 4 5 6 7
8 9 10 11 12 13 14
15 16 17 18 19 20 21
22 23 24 25 26 27 28
29 30 31
使用許諾
最新コメント
(08/15)
(05/04)
(03/06)
(03/04)
(09/25)
最新トラックバック
T/O
(11/05)